Uploaded image for project: 'Apache Guacamole - Contributions'
  1. Apache Guacamole - Contributions
  2. GUAC-1391 Release 0.9.9
  3. GUAC-1426

Database upgrade script for 0.9.6 no longer correct

    XMLWordPrintable

    Details

    • Type: Defect
    • Status: Done
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Sprint:
      DEV 2015-12-18

      Description

      When 0.9.6 was released, it added the ability for users to change their own passwords, and added that permission to the set of default permissions granted to all new users. The 0.9.6 upgrade script does nothing more than grant those permissions retroactively to all existing users.

      The 0.9.8 release of Guacamole changed the way users are created. Because of this, the default permissions for new users are no longer "READ" and "UPDATE" on self; only "READ" on self is granted.

      See guacamole-client commit 7ea05b1.

        Attachments

          Activity

            People

            Assignee:
            james.muehlner James Muehlner
            Reporter:
            mike.jumper Michael Jumper
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: